Sekilas Mengenai Mikrotik

MikroTik RouterOS? adalah sistem operasi dan perangkat lunak yang dapat digunakan untuk menjadikan komputer manjadi router network yang handal, mencakup berbagai fitur yang dibuat untuk ip network dan jaringan wireless, cocok digunakan oleh ISP dan provider hostspot.

Belajar Mikrotik

Mikroik RouterOS adalah software yang dapat menyulap PC menjadi router network handal…(emang sih, pegalaman membuktikan).. ini adalah catatan pribadi waktu belajar mandiri mikrotik, mudah2 an yang lain bisa nambahin tips tips dan trik2 di mikrotik

Setup Mikrotik setlah di install
1. setelah mikrotik terinstall dengan baik dan benar jalankan mikrotik anda
2. masukkan username & password, karena masih baru maka default username : admin pasword : blank
3. Ganti nama ethernet anda jika anda mau, dalam hal ini anda dapat memberikan nama apa saja = [charter@mikrotik] >interface
[charter@mikrotik] interface >print (melihat dulu berapa banyak ethernet yg terpasang)
[charter@mikrotik] interface >set 0 name=LAN
[charter@mikrotik] interface >set 1 name=WAN
4. kemudian nambahkan ip addressnya
[charter@mikrotik] >ip address
[charter@mikrotik] ip address >add address=192.168.0.1/255.255.0.0 interface=LAN —-> ini untuk ip interface lokal
[charter@mikrotik] ip address >add address=203.90.1.1/255.255.255.240 interface=WAN —> ini untuk ip global yg di dapet dari ISP
5. kemudian masukin gatewaynya
[charter@mikrotik] > ip route
[charter@mikrotik] ip route >add gateway=xxx.xxx.xxx.xxx/xxx.xxx.xxx.xxx —-> ini merupakan gateway untuk keluar
6. kemudian setup webproxy
[charter@mikrotik] >ip web-proxy
[charter@mikrotik] ip web-proxy >set enable=yes
[charter@mikrotik] ip web-proxy >set transparent-proxy=yes
[charter@mikrotik] ip web-proxy >set max-object-size=1200KiB —> ini supaya nge loadnya cepat si web proxy
7. kemudian tambahkan rule supaya si client yg menggunakan port 80 akan di oper ke web-proxy
[charter@mikrotik] >ip firewall nat
[charter@mikrotik] ip firewall nat >add chain=dstnat protocol=tcp dst-port=80 action=redirect to-ports=3128
8. kemudian masukan dns nya
[charter@mikrotik] >ip dns
[charter@mikrotik] ip dns >set primary-dns=xxx.xxx.xxx.xxx
[charter@mikrotik] ip dns >set secondary-dns=xxx.xxx.xxx.xxx
9. Sekarang masqurade interface WANnya
[charter@mikrotik]>ip firewall nat
[charter@mikrotik] ip firewall nat>add chain=srcnat out-interface=WAN action=masquerade
10. sekarang coba ping ke gateway & dns dari mikrotik, kalo REPLY berarti dah konek

Skema/topologi jaringan

Koneksi Internet dengan menggunakan xDSL menggunakan modem, bisa lewat
infrastuktur telkom atau provider lainnya. Untuk koneksi melalui provider
wireless bisa disesuaikan

Keterangan skema

(1) = Modem xDSL (Ip Address : 192.168.1.1/24)
(2) = Mikrotik Box dengan 3 ethernet card yaitu a (publik), b (local) dan c (Proxy)
(3) = Switch

Untuk sambungan ke Client. Asumsi Client Jumlahnya 20 Client
Range Ip Address : 192.168.0.0/27
Alokasi Ip Client = 192.168.0.1-192.168.0.30
Ip Net ID : 192.168.0.0/27
Ip Broadcast : 192.168.0.31/27

(4) = Proxy Server Box

(b) Alokasi IP Address
[*] Mikrotik Box

Keterangan Skema
a = ethernet card 1 (Publik) -> Ip Address : 192.168.1.2/24
b = ethernet card 2 (Local) -> Ip Address : 192.168.0.30/27
c = ethernet card 3 (Proxy) -> Ip Address : 192.168.2.1/30

Gateway : 192.168.1.1 (ke Modem)
[*] Client
Client 1 – Client n, Ip Address : 192.168.0.n …. n (1-30)

Contoh:
Client 6
Ip Address : 192.168.0.6/27
Gateway : 192.168.0.30 (ke Mikrotik Box)
[*] Linux untuk Proxy

d = ethernet card 4 (Linux) -> Ip Address : 192.168.2.2/30
Gateway : 192.168.2.1/30 (ke ethernet 3 di Mikrotik)

Note :
– Angka dibelakang Ip address ( /27) sama dengan nilai netmasknya
untuk angka (/27) nilainya sama dengan 255.255.255.224.

Untuk sub netmask blok ip address Local kelas C, dapat diuraikan
sebagai berikut :

Subnetmask kelas C
——————-
255.255.255.0 = 24 -> 254 mesin
.. .128 = 25 -> 128 mesin
.. .192 = 26 -> 64 mesin
.. .224 = 27 -> 32 mesin
.. .240 = 28 -> 16 mesin
.. .248 = 29 -> 8 mesin
.. .252 = 30 -> 4 mesin
.. .254 = 31 -> 2 mesin
.. .255 = 32 -> 1 mesin

## Perlu dikurangin juga untuk 2 Ip adress yang tidak digunakan pada mesin.
Yaitu 1 ip address untuk Network ID dan 1 ip address untuk broadcast

– Susunan kabel UTP antara (2)-Mikrotik Box dengan (4)-Linux Box adalah Cross,

–[2]– Konfigurasi Dasar

Sebagaimana di gambarkan pada skema jaringan diatas, jenis sistem operasi yang perlu disiapkan ada Sistem Operasi untuk Router yaitu Mikrotik RouterOS versi 2.9.27 level 6 dan Sistem Operasi Gnu/Linux distro CentOs versi 4.4 yang dipakai nantinya untuk mesin Proxy.

Informasi untuk mikrotik ini dapat dilihat pada official websitenya di http://www.mikrotik.com ato di Indonesia http://www.mikrotik.co.id.

Silahkan siapkan dulu ISOnya, .

Begitu juga untuk Linux CentOsnya, silahkan download dahulu ISOnya di http://mirror.nsc.liu.se/CentOS/4.4/isos/i386/. CentOS ini versi 4.4.

Sesuaikan saja Sistem Operasinya jika, ingin menggunakan Sistem Operasi yang berbeda dari percobaan yang dilakukan. Misalnya untuk mikrotik memakai MT Versi 2.8.x atau diatasnya lagi, begitu juga dengan Linux, silahkan dipilih sendiri Distribusi yang disukai. Secara konsep konfigurasinya sama.

Nah, di anggap kedua mesin telah siap beroperasi tentu telah di installkan pada kedua mesin, Untuk Mikrotik silahkan lihat metode instalasinya di SINI juga di SINI. Sedangkan untuk CentOs, jika pembaca ingin membuat partisi khusus untuk /cache/ silahkan saja, Memang percobaan kali ini partisinya dibuat khusus.

Konfigurasi dasar.

(a) Mikrotik

– Instalasi paket SYSTEM, SECURITY, DHCP (optional)

– Set Ip addressnya sesuai dengan Skema, karena memeliki 3 card lan, maka
di set IP address untuk ketiga card tersebut. Sesuaikan nama interfacenya
berdasarkan skema diatas, berarti ada nama interface yaitu:
1. interface Public
2. interface Local
3. interface Proxy

#Interface
——————————————————————————-
[charter@MikroTik] interface> print
Flags: X – disabled, D – dynamic, R – running
# NAME TYPE RX-RATE TX-RATE MTU
0 R public ether 0 0 1500
1 R proxy ether 0 0 1500
2 R local ether 0 0 1500
[charter@MikroTik] interface>
——————————————————————————-

Tentu saja nama interface boleh tidak sesuai dengan nama diatas, terserah
pembaca. Yang jelas ketiga interface diatas memiliki Subnet Ip address ber
beda, perhatikan skema.

# IP Address
——————————————————————————
[charter@MikroTik] > ip address print
Flags: X – disabled, I – invalid, D – dynamic
# ADDRESS NETWORK BROADCAST INTERFACE
0 192.168.1.2/24 192.168.1.0 192.168.1.255 public
1 192.168.0.30/27 192.168.0.0 192.168.0.31 local
2 192.168.2.1/30 192.168.2.0 192.168.2.3 proxy
[admin@MikroTik] >
——————————————————————————

– Set Ip Gateway atau routing. Untuk mikrotik gatewaynya ke Modem yaitu 192.168.1.1

# Ip Gateway

————————————————————————————
[charter@MikroTik] > ip route print
Flags: X – disabled, A – active, D – dynamic,
C – connect, S – static, r – rip, b – bgp, o – ospf
# DST-ADDRESS PREFSRC G GATEWAY DISTANCE INTERFACE
0 ADC 192.168.2.0/30 192.168.2.1 proxy
1 ADC 192.168.0.0/27 192.168.0.30 local
2 ADC 192.168.1.0/24 192.168.1.2 public
3 A S 0.0.0.0/0 r 192.168.1.1 public
[charter@MikroTik] >
————————————————————————————

– Set DNS

#Ip DNS

————————————————————————————
[charter@MikroTik] > [charter@MikroTik] >
invalid command name
[charter@MikroTik] > ip dns print
primary-dns: 203.130.193.74
secondary-dns: 202.134.0.155
allow-remote-requests: yes
cache-size: 10240KiB
cache-max-ttl: 1w
cache-used: 271KiB
[charter@MikroTik] >
————————————————————————————

– Tambahkan rule di /ip firewall nat nya, untuk masquarade.

#Rule Firewall NAT, Redirect ke Web Proxy

————————————————————————————-
[charter@MikroTik] ip firewall nat> pr
Flags: X – disabled, I – invalid, D – dynamic
0 chain=srcnat out-interface=public action=masquerade

1 chain=dstnat src-address=192.168.0.0/27 protocol=tcp dst-port=80
action=redirect to-ports=8080

2 chain=dstnat src-address=192.168.0.0/27 protocol=tcp dst-port=8000
action=redirect to-ports=3128

3 chain=dstnat src-address=192.168.0.0/27 protocol=tcp dst-port=3128
action=redirect to-ports=8080
————————————————————————————-

# Bandwidth management dengan PCQ

### Set Trafik lewat Proxy dan Trafik Langsung

/ ip firewall mangle
add chain=prerouting src-address=192.168.n.n/27 action=mark-packet \
new-packet-mark=test-up passthrough=no comment=”UP TRAFFIC” disabled=no
add chain=forward src-address=192.168.14.n.n/27 action=mark-connection \
new-connection-mark=test-conn passthrough=yes comment=”CONN-MARK” \
disabled=no
add chain=forward in-interface=Public connection-mark=test-conn \
action=mark-packet new-packet-mark=test-down passthrough=no comment=” \
DOWN-DIRECT CONNECTION” disabled=no
add chain=output out-interface=Local dst-address=192.168.n.n/27 \
action=mark-packet new-packet-mark=test-down passthrough=no \
comment=”DOWN-VIA PROXY” disabled=no

##### Set PCQ type

/ queue type
add name=”pcq-download” kind=pcq pcq-rate=0 pcq-limit=50 \
pcq-classifier=dst-address pcq-total-limit=2000
add name=”pcq-upload” kind=pcq pcq-rate=0 pcq-limit=50 \
pcq-classifier=src-address pcq-total-limit=2000

####### ini Queue Treenya Simple Amat

/ queue tree
add name=”downstream” parent=Local packet-mark=test-down limit-at=0 \
queue=pcq-download priority=8 max-limit=0 burst-limit=0 burst-threshold=0 \
burst-time=0s disabled=no
add name=”upstream” parent=global-in packet-mark=test-up limit-at=0 \
queue=pcq-upload priority=8 max-limit=0 burst-limit=0 burst-threshold=0 \
burst-time=0s disabled=no

Referensi
primadonal.com
mikrotik.com

Daftar Website Tutorial Mikrotik :
1. Cara Menggunakan Mikrotik
2. Berita IT
3. Mikrotik Router
4. Dll

%d blogger menyukai ini: